Ludii Forum
Quarto - Printable Version

+- Ludii Forum (
+-- Forum: Problems (
+--- Forum: Website Problems (
+--- Thread: Quarto (/showthread.php?tid=769)

Quarto - Francis-Loop - 12-21-2021

I've tried to play Quarto via Browser (Mozilla) and the game (or is it me?) gets stuck.

The AI accepts and places the piece I picked. It seems to select one (it blinks, shortly) for me to place.
But I can't ?!?

As for the java AI player, it took me a while to understand
that the only way to get "what piece shall I play?" is trying to pick up all of the pieces. 
(will make that a separate post)

RE: Quarto - Eric Piette - 12-23-2021


I just tried the web version of that game and I do not get any problem.
Just in case I am going to ask Matthew (he implemented most of the web version) to look at it after his holidays, but for my side, I do not get any problem.


RE: Quarto - Francis-Loop - 12-29-2021

Hmm, the web player issue i can reprodruce on several computers...
(unlike the java player which was about color/scheme/blindness really)

Two AI players do actually work btw. But if it's my turn as a human player,
the web version won't let me place the piece.
it says "thinking" for a second or two but that's all it does.

RE: Quarto - Eric Piette - 12-31-2021


Yes, I reported the issue to Matthew which is going to look when he will be back from holidays (17th Jan).


RE: Quarto - MatthewStephenson - 01-17-2022


Are you able to provide the moves that you make to cause this issue?
When I make a move (as the white player), you first need to click on one of the pieces above the game board (they are very small but valid pieces will have a blue dot on them) and then click on a red dot on the board.

The Thinking... message simple means that the server is processing your mouse click. This message will be displayed even if the click you made was invalid.


RE: Quarto - Francis-Loop - 01-17-2022

And after several more tries, the red dots appeared!

The pieces are not only small enough to keep me from distinguishing blue dots from black pieces, they also had me miss-clicking pretty much the whole time. Basically, nothing was placed because nothing was selected. Thanks for your hint, and patience!

(Greetings from the proverbial user that is even more stupid :)